nix/configuration.nix
Stefan Schwarz 599d34d9cb updates
2024-10-08 13:06:54 +02:00

45 lines
997 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running nixos-help).
{ config, pkgs, ... }:
{
imports = [
# custom modules
./modules/colors.nix
# Include the results of the hardware scan.
./hardware-configuration.nix
# roles
./roles/admin.nix
./roles/base.nix
./roles/desktop.nix
./roles/dev.nix
./roles/mail.nix
./roles/network.nix
./roles/nix.nix
./roles/vpn.nix
./roles/work.nix
];
networking.useDHCP = false;
i18n.defaultLocale = "en_US.UTF-8";
time.timeZone = "Europe/Berlin";
services.openssh.enable = true;
networking.firewall.enable = true;
nixpkgs.config.permittedInsecurePackages = [
"openssl-1.0.2u"
"python3.10-kerberos-1.3.1"
];
# removed for mobile working
# system.autoUpgrade.enable = true;
system.stateVersion = "20.03"; # We can stay here
}