42 lines
1.1 KiB
Nix
42 lines
1.1 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
let unstable = import <nixos-unstable> { config.allowUnfree = true; };
|
||
in {
|
||
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
|
||
|
||
boot.initrd.availableKernelModules =
|
||
[ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
|
||
boot.initrd.kernelModules = [ "amdgpu" ];
|
||
boot.kernelModules = [ "kvm-amd" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" = {
|
||
device = "tank/root/nixos";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/home" = {
|
||
device = "tank/root/home";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/587C-36F9";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
# custom
|
||
boot.extraModprobeConfig = ''
|
||
options snd_usb_audio device_setup=1
|
||
'';
|
||
boot.loader.efi.canTouchEfiVariables = true;
|
||
boot.loader.systemd-boot.enable = true;
|
||
networking.hostId = "ef3a5d57";
|
||
networking.hostName = "home";
|
||
hardware.opengl.enable = true;
|
||
}
|