52 lines
1.4 KiB
Nix
52 lines
1.4 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
let
|
||
tuxedo-keyboard =
|
||
pkgs.callPackage (import ../packages/tuxedo-keyboard.nix) { };
|
||
tuxedo-cc =
|
||
pkgs.callPackage (import ../packages/tuxedo-control-center/default.nix) { };
|
||
in {
|
||
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
|
||
|
||
boot.initrd.availableKernelModules =
|
||
[ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ tuxedo-keyboard ];
|
||
environment.systemPackages = with pkgs; [ tuxedo-cc ];
|
||
|
||
fileSystems."/" = {
|
||
device = "private/root/nixos";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/home" = {
|
||
device = "private/root/home";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/tmp" = {
|
||
device = "private/root/tmp";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/7E36-C774";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
nix.maxJobs = lib.mkDefault 8;
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
|
||
# custom
|
||
boot.loader.systemd-boot.enable = true;
|
||
hardware.cpu.intel.updateMicrocode = true;
|
||
networking.hostId = "eff291c7";
|
||
networking.hostName = "ds9";
|
||
services.tlp.enable = true;
|
||
}
|