64 lines
1.8 KiB
Nix
64 lines
1.8 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, ... }:
|
||
|
||
let unstable = import <nixos-unstable> { config.allowUnfree = true; };
|
||
in {
|
||
imports = [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix> ];
|
||
|
||
boot.extraModulePackages = [ ];
|
||
boot.initrd.availableKernelModules =
|
||
[ "xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
|
||
boot.initrd.kernelModules = [ "i915" ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.kernelParams = [ "intel_pstate=active" ];
|
||
boot.extraModprobeConfig = ''
|
||
options snd_usb_audio device_setup=1
|
||
'';
|
||
|
||
nixpkgs.config.packageOverrides = pkgs: {
|
||
vaapiIntel = pkgs.vaapiIntel.override { enableHybridCodec = true; };
|
||
};
|
||
hardware.opengl = {
|
||
enable = true;
|
||
extraPackages = with pkgs; [
|
||
intel-media-driver # LIBVA_DRIVER_NAME=iHD
|
||
vaapiIntel # LIBVA_DRIVER_NAME=i965
|
||
vaapiVdpau
|
||
libvdpau-va-gl
|
||
];
|
||
};
|
||
environment.variables = {
|
||
VDPAU_DRIVER = lib.mkIf config.hardware.opengl.enable (lib.mkDefault "va_gl");
|
||
};
|
||
|
||
fileSystems."/" = {
|
||
device = "tank/work/nixos";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/home" = {
|
||
device = "tank/work/home";
|
||
fsType = "zfs";
|
||
};
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/DC7B-5E2D";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
nix.maxJobs = lib.mkDefault 12;
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
|
||
# custom
|
||
boot.loader.systemd-boot.enable = true;
|
||
hardware.cpu.intel.updateMicrocode = true;
|
||
networking.hostId = "eff291c4";
|
||
networking.hostName = "sphere";
|
||
services.tlp.enable = true;
|
||
services.hardware.bolt.enable = true;
|
||
|
||
}
|